fbpx

Jak skonstruować formułę tworzącą kalendarz na dowolny miesiąc?

kalendarz w excelu

Krok pierwszy:

Zaznacz komórki z zakresu C2:I2 i scal je. Następnie wpisz tam datę miesiąca, dla którego chcesz przygotować kalendarz.

Krok drugi:

Do komórek C3:I3 wprowadź nazw dni tygodnia.

Krok trzeci:

Zaznacz komórki z zakresu: C4:I9, a następnie w pasku formuły wpisz podaną poniżej formułę:

=JEŻELI(MIESIĄC(DATA(ROK(C2);MIESIĄC(C2);1))<>MIESIĄC(DATA(ROK(C2);MIESIĄC(C2);1)-(DZIEŃ.TYG(DATA(ROK(C2);MIESIĄC(C2);1))-1)+{0;1;2;3;4;5}*7+{1\2\3\4\5\6\7}-1);” “;DATA(ROK(C2);MIESIĄC(C2);1)-(DZIEŃ.TYG(DATA(ROK(C2);MIESIĄC(C2);1))-1)+{0;1;2;3;4;5}*7+{1\2\3\4\5\6\7}-1)

UWAGA. Jest to formuła tablicowa więc jej wprowadzenie zatwierdzamy kombinacją klawiszy Ctrl+Shift+Enter. Zatwierdzenie tej formuły samym klawiszem Enter nie zadziała lub pojawi się błąd.

Obszar C2:I9 sformatuj taj jak na zdjęciu. Aby w komórkach pojawiły się tylko numery dni miesiąca zastosuj dla nich formaty niestandardowe.

 

Imię
Nazwisko
Adres
Jan
Kowalski
Korkowa 5;Częstochowa
Stanisław
Nowak
Targowa 12/14;Kraków
Adam
Iksiński
Młoda 12;Warszawa
Anna
Iksińska
Domowa 1;Poznań
Monika
Kowalska
Szaserów 34/36;Warszawa
Mikołaj
Tokarczuk
Miodowa 3;Gdynia